]> code.delx.au - refind/blob - refind.spec
More documentation of copyrights and licenses.
[refind] / refind.spec
1 Summary: EFI boot manager software
2 Name: refind
3 Version: 0.10.0
4 Release: 1%{?dist}
5 Summary: EFI boot manager software
6 License: GPLv3
7 URL: http://www.rodsbooks.com/refind/
8 Group: System Environment/Base
9 Source: refind-src-%version.tar.gz
10 Requires: efibootmgr
11 BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
12
13 %define efiarch unknown
14 %ifarch i386
15 %define efiarch ia32
16 %endif
17 %ifarch i486
18 %define efiarch ia32
19 %endif
20 %ifarch i586
21 %define efiarch ia32
22 %endif
23 %ifarch i686
24 %define efiarch ia32
25 %endif
26 %ifarch x86_64
27 %define efiarch x64
28 %endif
29
30 # Directory in which refind.key and refind.crt files are found for
31 # signing of binaries. If absent, binaries are copied unsigned.
32 %define keydir /mnt/refind
33
34 %description
35
36 A graphical boot manager for EFI- and UEFI-based computers, such as all
37 Intel-based Macs and recent (most 2011 and later) PCs. rEFInd presents a
38 boot menu showing all the EFI boot loaders on the EFI-accessible
39 partitions, and optionally BIOS-bootable partitions on Macs and BIOS boot
40 entries on UEFI PCs with CSMs. EFI-compatbile OSes, including Linux,
41 provide boot loaders that rEFInd can detect and launch. rEFInd can launch
42 Linux EFI boot loaders such as ELILO, GRUB Legacy, GRUB 2, and 3.3.0 and
43 later kernels with EFI stub support. EFI filesystem drivers for ext2/3/4fs,
44 ReiserFS, Btrfs, NTFS, HFS+, and ISO-9660 enable rEFInd to read boot
45 loaders from these filesystems, too. rEFInd's ability to detect boot
46 loaders at runtime makes it very easy to use, particularly when paired with
47 Linux kernels that provide EFI stub support.
48
49 %prep
50 %setup -q
51
52 %build
53 if [[ -d /usr/local/UDK2014 ]] ; then
54 make
55 make fs
56 else
57 make gnuefi
58 make fs_gnuefi
59 fi
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 mkdir -p $RPM_BUILD_ROOT/usr/share/refind-%{version}/refind/
64
65 # Copy the rEFInd binaries (rEFInd proper and drivers) to /usr/share/refind-%{version},
66 # including signing the binaries if sbsign is installed and a %{keydir}/refind.key file
67 # is available
68 declare SBSign=`which sbsign 2> /dev/null`
69 if [[ -f %{keydir}/refind.key && -x $SBSign ]] ; then
70 $SBSign --key %{keydir}/refind.key --cert %{keydir}/refind.crt --output $RPM_BUILD_ROOT/usr/share/refind-%{version}/refind/refind_%{efiarch}.efi refind/refind_%{efiarch}.efi
71 mkdir -p $RPM_BUILD_ROOT/usr/share/refind-%{version}/refind/drivers_%{efiarch}
72 for File in `ls drivers_%{efiarch}/*_x64.efi` ; do
73 $SBSign --key %{keydir}/refind.key --cert %{keydir}/refind.crt --output $RPM_BUILD_ROOT/usr/share/refind-%{version}/refind/$File $File
74 done
75 mkdir -p $RPM_BUILD_ROOT/usr/share/refind-%{version}/refind/tools_%{efiarch}
76 $SBSign --key %{keydir}/refind.key --cert %{keydir}/refind.crt --output $RPM_BUILD_ROOT/usr/share/refind-%{version}/refind/tools_%{efiarch}/gptsync_%{efiarch}.efi gptsync/gptsync_%{efiarch}.efi
77 else
78 install -Dp -m0644 refind/refind*.efi $RPM_BUILD_ROOT/usr/share/refind-%{version}/refind/
79 mkdir -p $RPM_BUILD_ROOT/usr/share/refind-%{version}/refind/drivers_%{efiarch}
80 cp -a drivers_%{efiarch}/* $RPM_BUILD_ROOT/usr/share/refind-%{version}/refind/drivers_%{efiarch}/
81 mkdir -p $RPM_BUILD_ROOT/usr/share/refind-%{version}/refind/tools_%{efiarch}
82 install -Dp -m0644 gptsync/gptsync_%{efiarch}.efi $RPM_BUILD_ROOT/usr/share/refind-%{version}/refind/tools_%{efiarch}/gptsync_%{efiarch}.efi
83 fi
84
85 # Copy configuration and support files to /usr/share/refind-%{version}
86 install -Dp -m0644 refind.conf-sample $RPM_BUILD_ROOT/usr/share/refind-%{version}/refind/
87 cp -a icons $RPM_BUILD_ROOT/usr/share/refind-%{version}/refind/
88 rm -rf $RPM_BUILD_ROOT/usr/share/refind-%{version}/refind/icons/svg
89 install -Dp -m0755 refind-install $RPM_BUILD_ROOT/usr/share/refind-%{version}/
90
91 # Copy documentation to /usr/share/doc/refind-%{version}
92 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/refind-%{version}
93 cp -a docs/Styles $RPM_BUILD_ROOT/usr/share/doc/refind-%{version}/
94 cp -a docs/refind $RPM_BUILD_ROOT/usr/share/doc/refind-%{version}/
95 install -Dp -m0644 NEWS.txt COPYING.txt LICENSE.txt README.txt CREDITS.txt $RPM_BUILD_ROOT/usr/share/doc/refind-%{version}
96
97 # Copy man pages to /usr/share/man/man8
98 mkdir -p $RPM_BUILD_ROOT/usr/share/man/man8
99 install -Dp -m0644 docs/man/mvrefind.8 $RPM_BUILD_ROOT/usr/share/man/man8
100 install -Dp -m0644 docs/man/mkrlconf.8 $RPM_BUILD_ROOT/usr/share/man/man8
101 install -Dp -m0644 docs/man/refind-install.8 $RPM_BUILD_ROOT/usr/share/man/man8
102
103 # Copy keys to /etc/refind.d/keys
104 mkdir -p $RPM_BUILD_ROOT/etc/refind.d/keys
105 install -Dp -m0644 keys/* $RPM_BUILD_ROOT/etc/refind.d/keys
106
107 # Copy scripts to /usr/sbin
108 mkdir -p $RPM_BUILD_ROOT/usr/sbin
109 install -Dp -m0755 mkrlconf $RPM_BUILD_ROOT/usr/sbin/
110 install -Dp -m0755 mvrefind $RPM_BUILD_ROOT/usr/sbin/
111 ln -sr $RPM_BUILD_ROOT/usr/share/refind-%{version}/refind-install $RPM_BUILD_ROOT/usr/sbin
112
113 # Copy banners and fonts to /usr/share/refind-%{version}
114 cp -a banners $RPM_BUILD_ROOT/usr/share/refind-%{version}/
115 cp -a fonts $RPM_BUILD_ROOT/usr/share/refind-%{version}/
116
117 %clean
118 #rm -rf $RPM_BUILD_ROOT
119
120 %files
121 %defattr(-,root,root -)
122 %doc /usr/share/doc/refind-%{version}
123 %doc /usr/share/man/man8
124 /usr/sbin/mkrlconf
125 /usr/sbin/mvrefind
126 /usr/sbin/refind-install
127 /usr/share/refind-%{version}
128 /etc/refind.d/
129
130 %post
131 PATH=$PATH:/usr/local/bin
132 # Remove any existing NVRAM entry for rEFInd, to avoid creating a duplicate.
133 ExistingEntry=`efibootmgr | grep "rEFInd Boot Manager" | cut -c 5-8`
134 if [[ -n $ExistingEntry ]] ; then
135 efibootmgr --bootnum $ExistingEntry --delete-bootnum &> /dev/null
136 fi
137
138 cd /usr/share/refind-%{version}
139
140 if [[ -f /sys/firmware/efi/vars/SecureBoot-8be4df61-93ca-11d2-aa0d-00e098032b8c/data ]] ; then
141 IsSecureBoot=`od -An -t u1 /sys/firmware/efi/vars/SecureBoot-8be4df61-93ca-11d2-aa0d-00e098032b8c/data | tr -d '[[:space:]]'`
142 else
143 IsSecureBoot="0"
144 fi
145 # Note: Two find operations for ShimFile favors shim over PreLoader -- if both are
146 # present, the script uses shim rather than PreLoader.
147 declare ShimFile=`find /boot -name shim\.efi -o -name shimx64\.efi -o -name PreLoader\.efi 2> /dev/null | head -n 1`
148 if [[ ! -n $ShimFile ]] ; then
149 declare ShimFile=`find /boot -name PreLoader\.efi 2> /dev/null | head -n 1`
150 fi
151 declare SBSign=`which sbsign 2> /dev/null`
152 declare OpenSSL=`which openssl 2> /dev/null`
153
154 # Run the rEFInd installation script. Do so with the --shim option
155 # if Secure Boot mode is suspected and if a shim program can be
156 # found, or without it if not. If the sbsign and openssl programs
157 # can be found, do the install using a local signing key. Note that
158 # this option is undesirable for a distribution, since it would
159 # then require the user to enroll an extra MOK. I'm including it
160 # here because I'm NOT a distribution maintainer, and I want to
161 # encourage users to use their own local keys.
162 if [[ $IsSecureBoot == "1" && -n $ShimFile ]] ; then
163 if [[ -n $SBSign && -n $OpenSSL ]] ; then
164 ./refind-install --shim $ShimFile --localkeys --yes
165 else
166 ./refind-install --shim $ShimFile --yes
167 fi
168 else
169 if [[ -n $SBSign && -n $OpenSSL ]] ; then
170 ./refind-install --localkeys --yes
171 else
172 ./refind-install --yes
173 fi
174 fi
175
176 # CAUTION: Don't create a %preun or a %postun script that deletes the files
177 # installed by refind-install, since that script will run after an update,
178 # thus wiping out the just-updated files.
179
180 %changelog
181 * Sun Nov 8 2015 R Smith <rodsmith@rodsbooks.com> - 0.10.0
182 - Updated spec file for 0.10.0
183 * Sat Sep 19 2015 R Smith <rodsmith@rodsbooks.com> - 0.9.2
184 - Updated spec file for 0.9.2
185 * Sun Sep 13 2015 R Smith <rodsmith@rodsbooks.com> - 0.9.1
186 - Updated spec file for 0.9.1
187 * Sun Jul 26 2015 R Smith <rodsmith@rodsbooks.com> - 0.9.0
188 - Updated spec file for 0.9.0
189 * Sun Mar 1 2015 R Smith <rodsmith@rodsbooks.com> - 0.8.7
190 - Updated spec file for 0.8.7
191 * Sun Feb 8 2015 R Smith <rodsmith@rodsbooks.com> - 0.8.6
192 - Updated spec file for 0.8.6
193 * Sun Feb 1 2015 R Smith <rodsmith@rodsbooks.com> - 0.8.5
194 - Updated spec file for 0.8.5
195 * Mon Dec 8 2014 R Smith <rodsmith@rodsbooks.com> - 0.8.4
196 - Updated spec file for 0.8.4
197 * Sun Jul 6 2014 R Smith <rodsmith@rodsbooks.com> - 0.8.3
198 - Updated spec file for 0.8.3
199 * Sun Jun 8 2014 R Smith <rodsmith@rodsbooks.com> - 0.8.2
200 - Updated spec file for 0.8.2
201 * Thu May 15 2014 R Smith <rodsmith@rodsbooks.com> - 0.8.1
202 - Updated spec file for 0.8.1
203 * Sun May 4 2014 R Smith <rodsmith@rodsbooks.com> - 0.8.0
204 - Updated spec file for 0.8.0
205 * Sun Apr 20 2014 R Smith <rodsmith@rodsbooks.com> - 0.7.9
206 - Updated spec file for 0.7.9
207 * Sun Mar 9 2014 R Smith <rodsmith@rodsbooks.com> - 0.7.8
208 - Updated spec file for 0.7.8
209 * Fri Jan 3 2014 R Smith <rodsmith@rodsbooks.com> - 0.7.7
210 - Created spec file for 0.7.7 release