]> code.delx.au - offlineimap/blobdiff - debian/rules
* Fix clean target in debian/rules to allow for proper failure handling.
[offlineimap] / debian / rules
old mode 100644 (file)
new mode 100755 (executable)
index 7e29b28..7f62bf1
@@ -6,9 +6,6 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-# This is the debhelper compatibility version to use.
-export DH_COMPAT=4
-
 PYTHON=python
 PACKAGE=offlineimap
 
@@ -47,7 +44,7 @@ clean:
        rm -f build-stamp configure-stamp
 
        # Add here commands to clean up after the build process.
-       -$(MAKE) clean
+       [ ! -f Makefile ] || $(MAKE) clean
 
        dh_clean