]> code.delx.au - refind/blob - refind-alt.spec
Fix to Tom Briden's recent touch-screen commit; the original commit
[refind] / refind-alt.spec
1 Name: refind
2 Version: 0.6.4
3 Release: alt1
4
5 Summary: EFI boot manager software
6 License: GPLv3
7 Group: System/Base
8
9 Url: http://www.rodsbooks.com/refind/
10 Source0: refind-src-%version.zip
11 Source1: os_altlinux.icns
12 Packager: Michael Shigorin <mike@altlinux.org>
13
14 BuildRequires: gnu-efi unzip
15 BuildRequires: rpm-macros-uefi sbsigntools alt-uefi-keys-private
16 Requires: efibootmgr
17 Provides: refind-signed
18
19 %define refind_lib %_efi_bindir
20 %define refind_data %_datadir/%name
21
22 %ifarch x86_64
23 %define _efi_arch x64
24 %endif
25 %ifarch %ix86
26 %define _efi_arch ia32
27 %endif
28
29 %description
30 A graphical boot manager for EFI- and UEFI-based computers, such as all
31 Intel-based Macs and recent (most 2011 and later) PCs. rEFInd presents a
32 boot menu showing all the EFI boot loaders on the EFI-accessible
33 partitions, and optionally BIOS-bootable partitions on Macs. EFI-compatbile
34 OSes, including Linux, provide boot loaders that rEFInd can detect and
35 launch. rEFInd can launch Linux EFI boot loaders such as ELILO, GRUB
36 Legacy, GRUB 2, and 3.3.0 and later kernels with EFI stub support. EFI
37 filesystem drivers for ext2/3/4fs, ReiserFS, HFS+, and ISO-9660 enable
38 rEFInd to read boot loaders from these filesystems, too. rEFInd's ability
39 to detect boot loaders at runtime makes it very easy to use, particularly
40 when paired with Linux kernels that provide EFI stub support.
41
42 %prep
43 %setup
44
45 %build
46 make gnuefi
47 make fs_gnuefi
48
49 %install
50 mkdir -p %buildroot{%refind_lib{,/drivers_%_efi_arch},%refind_data}
51
52 %ifarch x86_64
53 for file in refind/refind*.efi; do
54 sbsign --key %_efi_keydir/altlinux.key --cert %_efi_keydir/altlinux.crt \
55 --output %buildroot%_efi_bindir/"`basename "$file"`" "$file"
56 done
57 for file in drivers_%_efi_arch/*_x64.efi; do
58 sbsign --key %_efi_keydir/altlinux.key --cert %_efi_keydir/altlinux.crt \
59 --output %buildroot%refind_lib/"$file" "$file"
60 done
61 %endif
62
63 %ifarch %ix86
64 install -pm644 refind/refind*.efi %buildroot%refind_lib/
65 cp -a drivers_%_efi_arch/*.efi %buildroot%refind_lib/drivers_%_efi_arch/
66 %endif
67
68 cp -a icons/ %buildroot%refind_data/
69 cp -a %SOURCE1 %buildroot%refind_data/icons/
70
71 %files
72 %doc docs/*
73 %doc NEWS.txt COPYING.txt LICENSE.txt README.txt CREDITS.txt
74 %doc install.sh mkrlconf.sh mvrefind.sh
75 %refind_lib
76 %refind_data
77
78 # TODO:
79 # - create separate signing helper
80 # - move off hardwired sbsign to that
81 # NB:
82 # - macros get expanded too early for shell loops
83
84 %changelog
85 * Sat Jan 12 2013 Michael Shigorin <mike@altlinux.org> 0.6.4-alt1
86 - initial build for ALT Linux Sisyphus
87 - stripped upstream installation helpers (too smart for a package)
88 - added os_altlinux icon
89
90 * Sun Jan 6 2013 R Smith <rodsmith@rodsbooks.com> - 0.6.3-2
91 - Fixed accidental inclusion of "env" as part of installation script
92
93 * Sun Jan 6 2013 R Smith <rodsmith@rodsbooks.com> - 0.6.3
94 - Created spec file for 0.6.3 release