]> code.delx.au - offlineimap/blob - debian/rules
Bump version number
[offlineimap] / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4 # Modified by John Goerzen
5
6 # Uncomment this to turn on verbose mode.
7 #export DH_VERBOSE=1
8
9 PYTHON=python
10 PACKAGE=offlineimap
11
12
13 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
14 CFLAGS += -g
15 endif
16 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
17 INSTALL_PROGRAM += -s
18 endif
19
20 configure: configure-stamp
21 configure-stamp:
22 dh_testdir
23 # Add here commands to configure the package.
24 #$(PYTHON) setup.py configure
25
26 touch configure-stamp
27
28
29 build: build-stamp
30
31 build-stamp: configure-stamp
32 dh_testdir
33
34 # Add here commands to compile the package.
35 $(PYTHON) setup.py build
36 make doc
37 #/usr/bin/docbook-to-man debian/pygopherd.sgml > pygopherd.1
38
39 touch build-stamp
40
41 clean:
42 dh_testdir
43 dh_testroot
44 rm -f build-stamp configure-stamp
45
46 # Add here commands to clean up after the build process.
47 [ ! -f Makefile ] || $(MAKE) clean
48
49 dh_clean
50
51 install: build
52 dh_testdir
53 dh_testroot
54 dh_clean -k
55 dh_installdirs
56
57 # Add here commands to install the package into debian/pygopherd.
58 #$(MAKE) install DESTDIR=$(CURDIR)/debian/pygopherd
59 $(PYTHON) setup.py install --root=`pwd`/debian/$(PACKAGE) --no-compile
60
61
62 # Build architecture-dependent files here.
63 binary-arch: build install
64 # We have nothing to do by default.
65
66 # Build architecture-independent files here.
67 binary-indep: build install
68 dh_testdir
69 dh_testroot
70 # dh_installdebconf
71 dh_installdocs
72 dh_installexamples offlineimap.conf offlineimap.conf.minimal
73 dh_installmenu
74 # dh_installlogrotate
75 # dh_installemacsen
76 # dh_installpam
77 # dh_installmime
78 dh_installinit
79 dh_installcron
80 dh_installman offlineimap.1
81 dh_installinfo
82 # dh_undocumented
83 dh_installchangelogs
84 dh_link
85 dh_strip
86 dh_compress
87 dh_fixperms
88 # dh_perl
89 dh_pysupport
90 # dh_makeshlibs
91 dh_installdeb
92 dh_shlibdeps
93 dh_gencontrol
94 dh_md5sums
95 dh_builddeb
96
97 binary: binary-indep binary-arch
98 .PHONY: build clean binary-indep binary-arch binary install configure