]> code.delx.au - offlineimap/blob - debian/rules
Added build-dep on man-db
[offlineimap] / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4 # Modified by John Goerzen
5
6 # Uncomment this to turn on verbose mode.
7 #export DH_VERBOSE=1
8
9 # This is the debhelper compatibility version to use.
10 export DH_COMPAT=4
11
12 PYTHON=python
13 PACKAGE=offlineimap
14
15
16 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
17 CFLAGS += -g
18 endif
19 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
20 INSTALL_PROGRAM += -s
21 endif
22
23 configure: configure-stamp
24 configure-stamp:
25 dh_testdir
26 # Add here commands to configure the package.
27 #$(PYTHON) setup.py configure
28
29 touch configure-stamp
30
31
32 build: build-stamp
33
34 build-stamp: configure-stamp
35 dh_testdir
36
37 # Add here commands to compile the package.
38 $(PYTHON) setup.py build
39 make doc
40 #/usr/bin/docbook-to-man debian/pygopherd.sgml > pygopherd.1
41
42 touch build-stamp
43
44 clean:
45 dh_testdir
46 dh_testroot
47 rm -f build-stamp configure-stamp
48
49 # Add here commands to clean up after the build process.
50 -$(MAKE) clean
51
52 dh_clean
53
54 install: build
55 dh_testdir
56 dh_testroot
57 dh_clean -k
58 dh_installdirs
59
60 # Add here commands to install the package into debian/pygopherd.
61 #$(MAKE) install DESTDIR=$(CURDIR)/debian/pygopherd
62 $(PYTHON) setup.py install --root=`pwd`/debian/$(PACKAGE) --no-compile
63
64
65 # Build architecture-dependent files here.
66 binary-arch: build install
67 # We have nothing to do by default.
68
69 # Build architecture-independent files here.
70 binary-indep: build install
71 dh_testdir
72 dh_testroot
73 # dh_installdebconf
74 dh_installdocs
75 dh_installexamples offlineimap.conf offlineimap.conf.minimal
76 dh_installmenu
77 # dh_installlogrotate
78 # dh_installemacsen
79 # dh_installpam
80 # dh_installmime
81 dh_installinit
82 dh_installcron
83 dh_installman offlineimap.1
84 dh_installinfo
85 # dh_undocumented
86 dh_installchangelogs
87 dh_link
88 dh_strip
89 dh_compress
90 dh_fixperms
91 # dh_perl
92 dh_pysupport
93 # dh_makeshlibs
94 dh_installdeb
95 dh_shlibdeps
96 dh_gencontrol
97 dh_md5sums
98 dh_builddeb
99
100 binary: binary-indep binary-arch
101 .PHONY: build clean binary-indep binary-arch binary install configure